Back to overview
Resolved

MindCloud services are degraded

Apr 20, 2026 at 12:40pm UTC
Affected services
MindCloud Platform (app.mindcloud.co)
MindCloud API (api.mindcloud.co)
Webhooks (webhook.mindcloud.co)
Workflow Engine
Job Engine
Database Health

Resolved
Apr 20, 2026 at 2:50pm UTC

Our team investigated the source of the load, applied a mitigation, and confirmed that database performance returned to normal levels.

Created
Apr 20, 2026 at 12:40pm UTC

We identified elevated unusual load on our database infrastructure related to job executions. The increased load affected performance for some operations that depend on database reads.