Back to overview
Downtime

MindCloud services are degraded

Mar 26, 2026 at 1:33pm UTC
Affected services
mindcloud.co
MindCloud Platform (app.mindcloud.co)
MindCloud API (api.mindcloud.co)
Webhooks (webhook.mindcloud.co)
Embedded API (embedded.mindcloud.co)
Workflow Engine
Job Engine
Database Health

Resolved
Mar 26, 2026 at 1:45pm UTC

All services are now back online. We are closely monitoring the situation.

Created
Mar 26, 2026 at 1:33pm UTC

MindCloud had an incident where DNS records were accidentally deleted. These were reverted 10 minutes ago and we are working on restarting services to reflect the updated DNS status. This is ongoing.